
Guide 34 
Version 1.0 

Creating charts in Microsoft 
Excel 2003 
This guide provides an introduction to creating charts in Excel. It is assumed 
that the reader is familiar with the basics of Excel covered in Guide 33: An 
Introduction to Microsoft Excel 2003. 
A sample workbook referred to in the document is provided on the Networked 
PC service. Users of stand-alone PCs can get a copy from the Web. 
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Conventions: 

In this document, the following conventions are used: 
• A typewriter font is used for what you see on the screen. 
• A bold typewriter font is used to represent the actual characters you type at 

the keyboard. 
• A slanted typewriter font is used for items such as filenames which you 

should replace with particular instances. 
• A bold font is used to indicate named keys on the keyboard, for example, 

Esc and Enter, represent the keys marked Esc and Enter, respectively. 
• A bold font is also used where a technical term or command name is used 

in the text. 
• Where two keys are separated by a forward slash (as in Ctrl/B, for 

example), press and hold down the first key (Ctrl), tap the second (B), and 
then release the first key. 
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1 Charts 
A chart is a graphical representation of the data in your worksheet. You can 
create an embedded chart, which appears on the worksheet beside the 
data, or, you can create a chart sheet as a separate sheet in the workbook 
so that it can be displayed apart from its associated data. 

Whichever method you choose, your chart data is automatically linked to 
the worksheet from which it was created. If you change the data on the 
worksheet, the chart will change accordingly. 

Excel offers many different chart types, each of which has several subtypes 
or variations.  

Column  Bar  Line  Pie 
XY (scatter)  Area  Doughnut Radar 
Surface  Bubble  Stock  Cone 
Cylinder  Pyramid 

An Excel workbook called Data_for_Charts.xls has been prepared for you 
to use while working through this Guide. It contains data that can readily be 
displayed in chart form. 

If you are using a stand-alone PC, you may like to get a copy of this from 
the ITS WWW pages under Information | Guides | Sample Files 
(http://www.dur.ac.uk/its/info/guides/files/excel/). 

If you are using the Networked PC service: 

1 Activate Excel. 

2 From the File menu, select Open. 

3 Click on the 6 to the right of the Look in: box.  

4 Select the drive called workfile on ‘dudley’(T:). 

5 Double-click on the folder its. 

6 Double-click on the folder Excel. 

7 Select the file Data_for_Charts.xls and click the Open button. 

2 Creating a pie chart 
Pie is probably the simplest chart type so that will be used as the first 
example. 

A pie chart shows the relationship (proportional size) of items in a data 
series to the sum of all those items. It can only show one data series and is 
useful when you want to emphasise a significant item. To make small slices 
easier to see, you can group them together as one item in a pie chart and 
then break down that item in a smaller pie or bar chart next to the main 
chart. 

1 Click on the Food worksheet tab. 
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You will see data detailing the expenditure on different types of food. 

2 Click on any cell in the range B5:C11. 

3 Either 

Click on the Chart Wizard button on the toolbar 

or 

Select Chart from the Insert menu. 

The first Chart Wizard dialog box will appear. 

2.1 Choosing the chart type 

 

The Chart Wizard – Step 1 of 4 – Chart Type dialog box that appears has 
two tabs. The popular built-in chart types can be found on the Standard 
Types tab. Chart types designed by you, the user, and combination charts 
designed by Excel, can be found on the Custom Types tab (these will be 
dealt with in section 6.3). 

1 Make sure that the Standard Types tab is selected. 

At the moment, Column is selected in the Chart type: box. To see what 
your data would look like displayed as a column chart, 

2 Hold down the mouse on the Press and Hold to View Sample 
button. 

3 When you have finished looking at the chart in the Sample: box, 
release the mouse button. 

4 Click on Pie in the Chart type: box. 
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5 Make sure that the first option in the Chart sub-type: box has been 
selected (is highlighted). 

6 Click Next> (or press Enter) to move to the next step. 

2.2 Specifying which data is to be plotted 

 

Since you selected a cell in your data range before starting to create a 
chart, Excel should have correctly guessed that the data to be plotted is in 
cells B5:C11 of the Food worksheet. 

1 Check that the Data range: box is set to =Food!$B$5:$C$11. 

If the range is not correct, you can change it by editing it or by selecting the 
range to be plotted. 

2 Check that the Series in: setting is Columns. 

Excel usually makes the correct choice for this setting. It assumes that your 
data has more points than series. Your data has one series consisting of 
seven amounts of money (points). 

3 Click on the Series tab. 

Here you can confirm that Excel believes that you have one series 
(Series1) with values in C5:C11. The Category Labels: box is set to 
=Food!$B$5:$B$11. This means that your text Cakes, Sandwiches, and 
so on, will be used as labels if you request them.  

You could give a name to your series, which would then appear on the 
chart. For now though, leave the Name: box empty. 

4 Click on Next>. 
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2.3 Choosing chart options 

 

The number of tabs displayed in the Chart Wizard – Step 3 of 4 – Chart 
Options window varies, depending on the chart type. Here you have three 
— Titles, Legend and Data Labels. 

First enter the text to be used as a title for your chart. 

1 Make sure that the Titles tab is selected. 

2 Click in the Chart title: box and type 

Cost of food 

A title is an ordinary text box so when the chart has been created you will 
be able to move, reformat and edit the title. 

Next, deal with the legend (the key for the chart). 

3 Click on the Legend tab. 

4 Make sure that there is a tick beside Show legend. 

At the moment, the legend is on the right-hand side of the chart. 

5 In the Placement area, click on Bottom.  

Note how the legend has moved in the preview. The default is to position it 
on the right-hand side. Once the chart has been created, you can move the 
legend by dragging it and change the font of the text. 

Finally, consider the data labels. 

6 Click on the Data Labels tab. 

7 Click in the Category name box, note the effect on the preview and 
then remove the tick. 

8 Repeat for Value and Percentage. 

9 Make sure that no boxes are ticked in the Label Contains pane. 

10 Click on Next>. 
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2.4 Choosing the location of the chart 

 

In the Chart Wizard – Step 4 of 4 – Chart Location window, you can 
specify where this new chart is to go. 

You can choose to place the chart  

• As new sheet in which case a chart sheet containing just the chart 
will be entered in your workbook — type a name for the sheet in the 
adjacent box. 

• As object in so that the chart will be placed in an existing worksheet 
— the current one where your data is, or a different one (click on the 
down-arrow to select one). 

1 Click the As new sheet: button. 

2 Change the name Chart1 to FoodChart. 

3 Click on Finish. 

 

The Chart toolbar will probably appear — just drag it to a clear region of 
your chart. 
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2.5 Controlling the size of a chart on a chart sheet 
A chart placed on a chart sheet is created at a standard size and stays that 
size even if the window size is changed. So, if you make your window 
smaller, only part of the chart will be visible at any one time. However, there 
is a display mode in which the chart size changes when the window size 
changes. To demonstrate all that: 

1 Make sure that the FoodChart sheet is selected. 

2 Make the Data_for_Charts.xls window smaller (click on its Restore 
Down button and then drag a corner). 

Only part of your chart will be visible. 

3 Click on the Maximize button to return your window to its original 
size. 

You should now be able to see all of your chart again. 

Next, try using the different display mode: 

1 Select Options from the Tools menu. 

2 Click the Chart tab. 

3 Tick the Chart sizes with window frame box. 

4 Click OK. 

To see what difference this makes: 

1 Re-size your window by clicking on the Restore Down button. 

This time, you should still be able to see the whole chart. 

2 Click on the Maximize button to return your window to its original 
size. 

3 Formatting 
Before formatting a chart, it must be selected.  

1 Make sure the FoodChart chart sheet is active. 

2 Click on a blank region of the chart. 

Note that: 

• The border with eight small black handles indicates that the chart can 
be changed.  

• The Chart menu replaces the Data menu. 

3.1 Changing the format of the legend 

1 Single-click on the legend (the box containing the text Cakes, 
Sandwiches, and so on) to select it. 

The handles are now around the legend indicating that it can be altered. 
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2 From the Format menu, select Selected Legend. 

3 In the Format Legend dialog box that appears, click on the Font 
tab. 

4 In the Size: box, change the font size to 11. 

5 Click on OK. 

The contents of the legend are now easier to read. 

3.2 Changing the format of the chart title 

1 Click on the chart title Cost of food. 

2 From the Format menu, select Selected Chart Title. 

3 In the Font style: box, select Bold Italic. 

4 In the Size: box, choose 14. 

5 Click on OK. 

6 Click in a blank region away from the chart title to de-select it. 

Note: It is possible to change the font and colour of all the text in a chart 
(title, legend, and so on) at the same time. To do this, click in the Chart 
Area; from the Format menu select Selected Chart Area; click the Font 
tab; make your chosen adjustments and click OK. 

3.3 Changing a colour in the chart 
You may not like the colours that Excel has chosen for the various sectors 
of the pie chart. It is easy to change them. 

1 Click in the Sandwiches area of the pie chart. 

Handles will appear around all parts of the pie indicating that all the pie is 
selected. 

2 Click again in the Sandwiches area. 

This time the handles are around just the Sandwiches sector indicating 
that only it is selected. 

3 Click on the 6 of the Fill Color button (in the formatting toolbar near 
the top of the screen). 

4 Click on an appropriate colour (different from others in use in the pie 
chart). 

Note how the new colour appears in the legend as well as in the pie chart. 

5 Click on a blank region inside the chart’s frame, but away from the 
pie area, to deselect that sector. 
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3.4 Changing the labels 
Once your chart has been created, you may decide that you would like to 
change its data labels. 

1 Right-click in the Pie area and select Format Data Series from the 
shortcut menu (or left-click in the Pie area and, from the Format 
menu, select Selected Data Series). 

2 In the Format Data Series dialog box, click on the Data Labels tab. 

3 Tick the Percentage box and then click on OK. 

Because four of the slices are thin, their labels may be too close to each 
other. This can be rectified. 

4 Click twice (slowly) to select just the 2% label for Orange juice. 

5 Drag an edge of this text box to reposition it in a clear area. 

Note the line connecting the 2% label to its pie slice. 

6 Move the other data labels so that you get something like this: 

 

3.5 Formatting the background 
There are many ways of formatting the background areas of charts — the 
plot area, chart area, legends, titles, data labels, and so on. They include: 

• formatting the border 
• filling with a solid colour (as for the pie slice above) 
• filling with a colour gradient 
• filling with a pattern 
• filling with a texture or picture 

A colour gradient gives a smooth change of colour across the area you fill. 
There are two kinds of colour gradient: 
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• one-colour in which the chosen colour is varied by 
adding/subtracting luminosity 

• two-colour in which the first colour is gradually changed as you 
move across the area until the second colour dominates 

As an example, try shading your chart area with a colour gradient: 

1 Click in the background area of the chart (the mouse pointer 
message will be Chart Area). 

2 From the Format menu, select Selected Chart Area. 

3 In the Format Chart Area dialog box, click on the Patterns tab. 

4 Click on the Fill Effects button in the Area box. 

Now experiment with a few settings but do not press the OK button yet. 

5 In the Colors pane, click on Two colors. 

6 Click on the down-arrow beside Color 1 and select a colour. 

7 Click on the down-arrow beside Color 2 and select a colour. 

8 Look at the Sample: box to see what effect you have created. 

9 Experiment with different settings for Shading styles and Variants. 

10 Click on Preset in the Colors area. 

11 In the Preset colors: box, select something you like, perhaps 
Daybreak. 

12 Now click on OK. 

13 In the Format Chart Area dialog box, click OK. 

3.6 Changing a border 
Have a look at what could be done to the legend’s border: 

1 Click on the legend. 

2 From the Format menu, select Selected Legend. 

3 In the Format Legend dialog box, experiment with choosing 
different Style, Color, and Weight settings but don’t press OK for 
the moment. Instead, look in the Sample box to see what effects 
you are creating. 

4 Now, in order to remove the border from the legend, click on None 
in the Border area of the dialog box. 

5 Click on OK. 

6 Finally, de-select the legend by clicking outside its edge. 

For most data you would probably by now have a pie chart that you were 
happy with. However, with this particular data there is a slightly 
unsatisfactory feature in that four of the slices (Coke, Lemonade, Mineral 
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water and Orange juice) are very thin. It would really be better to combine 
these in the main pie chart (thinking of them as Soft drinks) and have an 
extra little pie chart detailing the Soft drinks beside the main pie chart. This 
is known as a pie-of-pie chart. You can also have bar-of-pie charts in 
which the extra chart is a bar one rather than a pie. 

If you would like to learn about creating pie-pie charts, exploding pie charts, 
or changing the positioning of the slices in a pie chart, work through the 
next section. Otherwise, skip to section 5. 

4 Other ways of changing a pie chart 

4.1 Converting from a pie to a pie-of-pie chart 

1 Click on the pie itself. 

2 From the Chart menu, select Chart Type. 

3 In the Chart type dialog box, check that the Chart type is set to Pie. 

4 In the Chart sub-type: box, select the third option in the first row. 

5 Hold down the Press and Hold to View Sample button — the 
sample should look similar to the chart shown below. 

6 Click on OK. 

 

Excel will have merged Lemonade, Mineral water and Orange juice but 
not Coke. So, the next step is to include Coke in the right-hand detail chart. 

A chart can be split by: 

• position — the last n points in your data series go to the detail chart 
• absolute value — all points less than a specified value n go to the 

detail chart 
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• percent value — all slices less than n% of the total go to the detail 
chart 

• manual selection — slices can be dragged from the main to the 
detail chart (at the appropriate stage, select Custom in the Split 
Series By drop-down list) 

Regardless of which way the splitting is done, Excel will redraw the main 
chart to show just a single slice representing all the slices in the detail 
chart. By default, lines will be drawn from the single slice to the detail chart. 
These lines can be removed (by deselecting the Series Lines checkbox at 
the appropriate time). 

So, you need to send the last four data values to the detail chart (instead of 
the last three). 

1 Click on the existing detail pie chart (on the right). 

2 Select Selected Data Series from the Format menu. 

3 In the Format Data Series dialog box, click on the Options tab. 

 

The Size of second plot: box, currently set to 75, controls the size of the 
detail plot in relation to the main pie chart. The number can be changed. 

The Gap width: box determines how close the detail plot is to the main 
plot. 

1 Click on the down-arrow in the Split series by: box to see what 
options there are but leave the setting at Position. 

2 Change the number in the Second plot contains the last: box to 4. 

3 Click on OK. 
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4 Change the shape of the legend and/or move the legend and/or 
move the data labels until you have an acceptable chart — similar to 
the one below. 

 

Note: It is also possible to move a slice from/to the main pie, to/from the 
pie-of-pie, simply by clicking and dragging the slice. 

4.2 Exploding pie charts 
You can move one, several, or all, of the slices in a pie chart away from the 
centre.  

If you would like to try this,  

1 Scroll to the region of cell B46 in the Food worksheet. 

Here you will find a simple pie chart. 

2 Point to any slice and drag it a small distance away from the centre. 

3 Release the mouse button. 

All the slices should have moved. 

4 Either drag them back or press the Undo button. 

5 Next select just the yellow slice (the handles will only be around that 
slice). 

6 Drag it away from the centre (only that slice will move). 

It is also possible to explode the outermost ring of a doughnut. 

4.3 Changing the starting position 
You may have noticed that pie and doughnut slices are always drawn in a 
clockwise order. Excel draws the radius for the beginning of the first slice in 
a pie (or doughnut) chart at the 12 o’clock position. You may feel that for 
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some particular chart you would like a different starting point. This can be 
arranged. 

1 Make sure that your pie chart is not exploded. 

2 Select all the slices. 

3 From the Format menu, select Selected Data Series. 

4 Click on the Options tab. 

5 The Angle of first slice: box will be set to 0 Degrees. 

6 Use the up-arrow to change that to 40 Degrees and note how the 
preview changes. 

7 Click OK. 

8 De-select the chart. 

5 Creating a line chart 
Pie charts do not have axes so, before dealing with axes, a different type of 
chart will have to be created.  

A line chart shows trends in data at equal intervals. 

1 Click on the ViewingFigures worksheet tab. 

This is a small worksheet containing viewing figures over a six-week period 
in the range B5:G8. Note that there is no data for the week ending 
14/05/00. 

2 Click anywhere within the table of data. 

3 Click on the Chart Wizard button. 

5.1 Chart type 
In the Chart Wizard – Step 1 of 4 – Chart Type dialog box: 

1 Make sure that the Standard Types tab is selected. 

2 Select Line in the Chart type: box. 

3 Check that the first Chart sub-type in the second row (Line with 
markers displayed at each data value) is selected. 

4 Briefly hold down the Press and Hold to View Sample button to get 
a preview of your chart. 

5 Click on Next>. 

5.2 Source data 
In the Chart Wizard – Step 2 of 4 – Chart Source Data dialog box: 

1 Make sure that the Data Range tab is selected. 
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2 Check that the Data range: will pick up the values in B5:G8. 

3 Check that the Series in: setting is Rows (all the values for a 
particular programme are in the same row). 

4 Click on the Series tab. 

 

You can now see that Excel believes that you have three series 
(Eastenders, Coronation Street and Emmerdale). 

Eastenders is selected and for that programme, the Name: is in B6 and 
the associated Values: are in C6:G6. 

The Category (X) axis labels to be used are set to C5:G5 (the dates).  

These are all correct assumptions but if something were wrong you could 
correct it at this stage. 

5 Click on Next>. 
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5.3 Titles 
In the Chart Wizard – Step 3 of 4 – Chart Options dialog box: 

1 Click on the Titles tab. 

2 In the Chart title: box, type a suitable heading for your chart, for 
example, 

Viewing figures 

3 Click in the Category (X) axis: box and enter some suitable text for 
the horizontal axis, for example, 

Week ending 

4 Click in the Value (Y) axis: box and enter some text for the vertical 
axis, for example, 

Number of viewers (in millions) 

5.4 Axes 

1 Click on the Axes tab. 

2 In the Primary axis box, click in the Category (X) axis box to 
remove the tick.  

In the preview, note how the axis has been removed together with its dates. 
This is not a sensible thing to do for this particular chart since there is now 
no way of knowing which weeks are involved. 

3 Click again in the Category (X) axis box to restore the tick (and the 
axis). 
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It is usually best to leave the Category (X) axis setting at Automatic. 
Excel will decide whether it is dealing with categories or dates/times along 
this axis and act accordingly. 

When Excel decides that it is dealing with time scaling rather than ordinary 
category scaling, it: 

• positions the data points in accordance with their chronological 
location (with categories Jan, Feb, and July, for example, Feb would 
appear closer to Jan than to July).  

• automatically plots the data in ascending chronological order even if 
the data was not presented in that order 

• uses the smallest time difference between data points as the base 
unit (but you can choose to work with a larger base unit). 

Time scaling is available for line, column, bar and area charts. 

Note that in your chart the week 14/05/00 is included on the axis even 
though there is no data for that week.  

5.5 Gridlines 
Gridlines are horizontal and vertical lines that help you to see where 
precisely a particular data marker is in relation to the axes. The defaults for 
most chart types involve some gridlines but you can add/remove them as 
you wish. 

1 Click on the Gridlines tab. 

2 Check that the Value (Y) axis has Major gridlines ticked. 

3 Click in the Category (X) axis Major gridlines box and note the 
appearance of new vertical gridlines in the preview. 

4 Click in that box again to remove the tick (and the extra gridlines). 

5.6 Legend 
Excel usually places a legend at the right-hand side of the chart. You can 
however move it or remove it. 

1 Click on the Legend tab. 

2 Leave the Show legend box ticked because a key is definitely 
needed for this particular chart. 

3 Experiment with various settings in the Placement box noting the 
effect they have in the preview box. Make sure that Right is the last 
one chosen. 

5.7 Data labels 
Various kinds of labels can be attached to data points. In section 3.4 you 
saw how percentages can be displayed for a pie chart. For each point in a 
line chart, you can display its series name (such as Eastenders), category 
name, or value. 
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1 Click on the Data Labels tab. 

2 All the boxes in the Label Contains area are currently clear. 

3 Click in the Value box — the data values (13.92, 15.37, …) will be 
displayed on the preview chart. 

4 Remove that tick. 

5 Click in the Category name box — the data labels (07/05/00, 
21/05/00, …) will be shown on the preview chart. 

For this particular chart the display is clearer without data values or data 
labels so, 

6 Remove the tick. 

5.8 Data Table 
For some chart types, Excel will offer to include a data table beside your 
chart. This contains the values from which the chart has been created. 

1 Click on the Data Table tab. 

2 Click in the Show data table box. 

3 In the preview, note how the data appears underneath your line 
chart. 

4 Clear the Show data table box. 

5 Click Next>. 

5.9 Location of chart 
Having created a chart, it can be placed: 

• on a separate chart sheet (supply a new name) 
• in an existing worksheet (choose one from the list offered) 

1 In the Chart Wizard – Step 4 of 4 – Chart Location dialog box, 
click on the As object in: button and select the current worksheet 
(ViewingFigures). 

2 Click on Finish. 

The chart is now complete but you will probably want to make some final 
adjustments. 

The eight small black squares (known as handles) on the frame around the 
chart indicate that the chart is currently selected. 

3 Click on the worksheet somewhere outside the chart area. This will 
de-select your chart and the squares will disappear. 
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5.10 Moving and resizing a chart 

1 Single-click on a blank region of the chart (note the re-appearance of 
the handles and the Chart toolbar). 

2 If the Chart toolbar is in the way, just drag it to a different position. 

3 Position the mouse pointer in the chart area (avoiding the plot area, 
title and legend). Hold down the mouse and drag the chart to a new 
position on the worksheet — place the top left-hand corner of the 
chart in the region of cell B14. 

4 Scroll down until you can point to the bottom right-hand corner of the 
chart (the cursor will change to a double-headed arrow). 

5 Drag that corner down and to the right until it is in the region of cell 
H33.  

Dragging a handle in the middle of one of the right or left-hand sides of a 
chart changes the chart’s width. Similarly, dragging a handle in the middle 
of the top or bottom of the chart changes the chart’s height. By dragging a 
corner, you can change both height and width at the same time. 

If you want to keep the centre of a chart fixed where it is and resize around 
that point, hold down Ctrl while dragging any handle. 

If you want to keep the ratio of width to height fixed (thereby maintaining 
the proportions of the chart), hold down the Shift key while dragging a 
corner handle. 

You may find that, although you have made your chart quite large, some 
details are still missing or the text is too large. Try reducing the font size as 
follows: 

1 Click on the 6 in the Font Size box on the formatting toolbar and 
select 8 pt (for example). 

5.11 Changing the size of the plot area 
The size of the line graph part of the chart can be changed without 
changing the overall size of the chart. 

1 Point to the line graph area (pointer message is Plot Area). 

2 Click the mouse button to select that area. 

3 Drag one of the corner handles until the area is the size you want. 

4 Click on the Chart Area outside the Plot Area. 

5.12 Changing the scale 
If the purpose of this chart is to compare the three programmes, rather than 
concentrate on the actual numbers of viewers, it would be appropriate to 
start the numbering of the Y axis at 8 rather than 0. 

1 Make sure the chart is selected. 
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2 Click on the Value axis (numbered from 0 to 20) — be sure to check 
that the correct pointer message is displayed before clicking. 

3 From the Format menu choose Selected Axis. 

4 Click on the Scale tab. 

This dialog box gives you control over the minimum and maximum values 
displayed on the axis. 

5 For the Value (Y) axis scale, set the Minimum to 8. 

6 Click OK. 

5.13 Final chart 
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6 Chart types 
There are many other chart types, including some with a 3D effect. Not all 
can be considered in this document but some should get special mention. If 
you are creating 3-D effect column or bar charts, consider using the cone, 
cylinder and pyramid data markers. 

If at any stage you would like to see examples of the various types of chart, 
proceed as follows: 

1 From the Help menu, select Microsoft Excel Help. 

2 Click on the Index tab. 

3 In box 1, type gallery and click the Search button. 

4 In box 3 select WEB: Gallery of chart examples. 

5 If you are offered a map, click on United Kingdom. 
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6.1 Standard chart types 
The main chart types are as follows (arranged in alphabetical order): 

6.1.1 Area chart 
An area chart shows the relative importance of values over a period of time. 
It is similar to a line chart but emphasises the amount of change 
(magnitude of values) rather than time and the rate of change. 

6.1.2 Bar chart 
Bar charts illustrate comparisons between items. Although they are similar 
to column charts, the categories on a bar chart are displayed vertically and 
the values are organised horizontally. This concentrates on comparing 
values and places less emphasis on time. A stacked bar chart shows the 
relationship of individual items to the whole. 

6.1.3 Bubble chart 
A bubble chart is a variation on an xy scatter plot. The size of the bubble 
(data marker) indicates the value of a third variable. Arrange the data with x 
values in one column (or row) and the corresponding y values and bubble 
size in the adjacent columns (rows). 

6.1.4 Column chart 
Column charts can be used to illustrate how data changes over a period of 
time, and to compare various items. Categories are displayed horizontally, 
values vertically. 

6.1.5 Doughnut chart 
Doughnut charts are similar to pie charts but, unlike pie charts, can show 
more than one data series. Each ring represents one data series. These 
charts are widely used in the Far East.  

6.1.6 Line chart 
This shows trends or changes in data over a period of time, at even 
intervals. A line chart emphasises time flow and rate of change rather than 
the amount of change. 

If you need to show trends or changes in data at uneven or clustered 
intervals, an xy (scatter) chart is more appropriate (see section 6.1.11).  

6.1.7 Pie chart 
A pie chart can only show one data series. It compares the size of 
individual items with the sum of them all. 

Guide 34: Creating charts in Microsoft Excel 2003 20



6.1.8 Radar chart 
This is another one widely used in the Far East. It looks like a badly-made 
spider’s web. It shows changes or frequencies of data series relative to a 
centre point and to one another. Each category has its own value axis 
radiating from the centre point. Lines connect all the values in the same 
series. 

6.1.9 Stock 
High-low-close and open-high-low-close charts are often used for stock 
prices. The open-high-low-close is sometimes called a candlestick chart. 
The high-low-close can also be used for scientific data, for example, to 
record temperature changes. It is essential to organise your data in the 
correct order before creating one of these charts, namely, high value 
followed by low and then close (or open value followed by high, low and 
then close). 

6.1.10 Surface 
A surface chart can be useful if you want to find optimum combinations 
between two sets of data. Colours and patterns are used to indicate areas 
that are in the same range of values. 

6.1.11 XY (Scatter) chart 
This is a widely used chart type. It shows the relationship (or degree of 
relationship) between numeric values in several data series, or, plots two 
groups of numbers as one series of xy coordinates. 

An xy scatter chart can deal with uneven intervals, or clusters, of data. It is 
frequently used for scientific data. When creating such a chart, the data is 
usually arranged with x values in one column (or row) and the 
corresponding y values in adjacent columns (or rows). 

6.2 Multi-level categories 
Excel allows you to categorise your categories. Look at the data and chart 
displayed below. 

The categories are in column C but further categories are in column B. This 
chart was created by selecting cells B5:G10 before creating a simple 
column chart.  

This type of display could be useful on some occasions. For example, if you 
had towns as your categories, the counties could be included as well to 
avoid confusion between town names that occur in more than one county. 

If you would like to experiment with this data, click on the MultiLevel 
worksheet tab. 
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6.3 Custom types 
Excel provides some useful and attractive chart types under the heading of 
custom types. These include black and white charts, combination charts 
like line with column, a chart with lines on two axes, and smooth lines. 
Rather than list them all it is much better to look at examples. 

1 Click on the CustomTypes worksheet tab. 

2 Click in one of the cells in the range B5:D9. 

3 Click on the Chart Wizard button. 

4 In the Chart Wizard – Step 1 of 4 – Chart Type dialog box, click on 
the Custom Types tab. 

5 In the Chart Type: box, methodically work your way through the 
options, clicking each in turn and looking at the preview to see what 
chart is created (but don’t click Finish). When you have looked at 
Floating Bars, scroll down to try the others. 

6 Click Cancel. 
If you have designed a particular kind of chart and often use that design, it 
would be sensible to add it to the custom types offered (see Section 9.2). 

7 Scatter plots 
These are very useful charts particularly for scientific data. First, a typical 
scatter plot will be created. Then it will be used as an example for changing 
the numbering on axes, adding best-fit straight lines and adding error bars. 

You can have up to 32,000 points per series for any 2D charts. The 
maximum number of data points allowed for all the data series in one chart 
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is 256,000. This enables large sets of scientific or financial data to be 
analysed. 

7.1 Creating a scatter plot 

1 Click on the Springs worksheet tab. 

Here you can see some suitable data that has already been prepared for 
you to use. The load values that will be plotted on the X axis are at uneven 
intervals (the lab only had one 5kg and three 15kg weights!). 

2 Select cells B6:D14 (do not select the Length (in metres) heading). 

3 Click on the Chart Wizard button. 

4 With the Standard Types tab selected, choose XY (Scatter) in the 
Chart type: box. 

5 In the Chart sub-type: box, select each option in turn and hold 
down the Press and Hold to View Sample button so that you are 
aware of the various options (with/without lines and so on). 

6 Select the first sub-type with description Scatter. Compares pairs 
of values. 

7 Click Next>. 

8 In the Chart Wizard - Step 2 of 4 - Chart Source Data dialog box, 
check that the Data range: setting is B6:D14 (on the Springs 
worksheet) and that Columns is selected. 

9 Click Next>. 

10 In the Chart Wizard - Step 3 of 4 – Chart Options dialog box, with 
the Titles tab selected, fill in the boxes as follows: 
Chart title:  Industrial springs 

Value (X) Axis: Load in kg 

Value (Y) Axis: Length in metres 

11 Click Next>. 

12 In the Chart Wizard - Step 4 of 4 – Chart Location dialog box, 
leave the Place chart: As object in: setting at Springs. 

13 Click on Finish. 

After a few adjustments, you should have something like the following 
chart. 
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At this stage, always quickly check that your data has been plotted 
correctly. 

7.2 Changing the colour of the plot area 
If your chart will be seen in colour, perhaps for a presentation, you may like 
to change the background colour of the plot area. 

1 Click in the plot area (make sure that the pointer shows the message 
Plot Area before you click). 

2 From the Format menu, choose Selected Plot Area… 

3 In the Format Plot Area dialog box, in the Area region, click on a 
pale colour such as turquoise blue. (If you would also like shading 
applied, click on the Fill Effects button.) 

4 Click OK. 

Having chosen a pale colour for the plot area, a good effect can be created 
by colouring the chart area in a slightly deeper shade (this leaves the plot 
area unchanged but gives a darker colour in the rest of the chart). 

7.3 Adding grid lines 
When you are in Excel and your chart is active, you can point precisely to a 
data point and a little message will appear telling you what values that point 
has. However, when you are interpreting a printed version it can sometimes 
be helpful if more gridlines are displayed. 

1 Make sure your chart is selected. 

2 From the Chart menu, select Chart Options. 

3 Click on the Gridlines tab. 

4 Change the settings of the Value (X) axis so that the Major 
gridlines box and the Minor gridlines box are ticked. 
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5 If necessary, change the settings of the Value (Y) axis so that the 
Major gridlines box is ticked but the Minor gridlines box is not 
ticked. 

6 Click on OK. 

Excel will insert minor gridlines for every 2kg. For this particular data every 
5kg would be more appropriate so that will have to be changed. 

7.4 Formatting an axis 

1 Make sure the chart is selected. 

2 Click on the Value (X) axis (check that the correct pointer message 
is displayed before clicking). 

3 From the Format menu choose Selected Axis. 

4 Click on the Scale tab. 

This dialog box gives you control over the minimum and maximum values 
displayed on the axis, and the place where the Y axis crosses. 

5 For the Value (X) axis scale, set the Minor unit to 5. 

6 Click OK. 

The chart should now have a vertical line through every multiple of 5kg. If 
you would like these extra gridlines to be numbered, 

1 Select the Value (X) axis. 

2 From the Format menu, choose Selected Axis. 

3 Click on the Scale tab. 

4 Change the Major unit setting to 5. 

5 Click OK. 

7.5 Adding a trend line 
Trendlines are used for analysing problems of prediction.You can extend a 
trendline in a chart forwards or backwards beyond the plotted data to show 
a trend. You can also create a moving average, which smooths out 
fluctuations in data and can show the pattern or trend more clearly. 

So, a trendline can be 

• a regression line that best fits the plotted data (of one series) 
• a line that plots a moving average of the values in a series 

Trendlines can be added to data series in unstacked 2-D area, bar, column, 
line, stock, xy (scatter), and bubble charts. You cannot add trendlines to 
data series in 3-D, stacked, radar, pie, or doughnut charts. If you change a 
chart that has trendlines to a type that does not support them, the 
trendlines will simply disappear. 
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For this particular data, a regression line is appropriate and will be added to 
the Type A spring data. 

1 Make sure the chart is selected. 

2 Click on one of the Type A data points (all of them will be selected). 

3 From the Chart menu, select Add Trendline. 

 

4 Note that several types of Trend/Regression are offered. (Excel’s 
built-in help has information about the equations used for the 
different types.) For this data the Linear one Based on series Type 
A is required.  

5 Click OK. 

 

6 Note how the regression line is now mentioned in the legend. 
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7.6 Displaying the equation 
Having added a regression line you may decide that you would like to have 
its equation appear with it (this could have been arranged when the line 
was created). 

1 Make sure that your chart is active. 

2 Click on the trendline (with pointer message “Type A” Trendline1). 

3 From the Format menu, select Selected Trendline. 

4 Click on the Options tab. 

Note that in this dialog box, you could 

• arrange to extrapolate forwards and/or backwards 
• force a particular intercept on the y axis 

5 Click in the Display equation on chart box. 

6 Click OK. 

The equation y = 0.021 x + 0.988 will be displayed beside the line. 

Always look critically at the equation — of the form y=mx+c — and ask 
yourself whether you were expecting that intercept (c) and slope (m). 

The equation may be rather illegible when superimposed on the gridlines. 
You could move the equation: 

1 Click on the equation. 

2 Drag its text box to a clearer region in the chart area (just to the right 
of the end of the line). 

3 If you want to draw attention to the equation, make sure its text box 
is selected and then click the Bold button on the formatting toolbar. 

 

7.7 Adding error bars 
Sometimes, when taking measurements, you know that errors have crept 
in. It can be helpful to show on the chart how confident you are in your 

Guide 34: Creating charts in Microsoft Excel 2003 27



data. Excel can add error bars to charts. As an example, add some error 
bars to the Type B spring data. 

1 Make sure that your chart is selected. 

2 Click on any one of the Type B data points (all of them will be 
selected). 

3 From the Format menu, select Selected Data Series. 

4 Click the Y Error Bars tab. 

 

In the Display group, there are settings to remove existing error bars 
(None) and to display the error bars as the data value  

• plus and minus some amount 
• plus some amount 
• minus some amount 
• with no error bar 

5 Click on Both. 

In the Error amount group you can indicate the size of the error bars you 
require. This can be a fixed amount for each point, a percentage of each 
value, the standard deviation, standard error or some custom one devised 
by you (the amount above the point could be different from the amount 
below). 

6 Click in the Percentage box; enter the number 15 (or use the up-
arrow to increase the current setting) and click on OK. 

7 Click on your worksheet away from the chart to see the final effect. 

Now that your chart has error bars, you may feel that it would look better 
without the X axis gridlines — just remove them to get the following chart. 
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7.8 Dragging chart markers 
So far, you have used data in a worksheet to produce a chart and you know 
that if you change the data in the worksheet, the chart will change 
accordingly. 

You can also change a chart and thereby change the data in your 
worksheet. As an example of this, move the last data point of the Type A 
spring as follows: 

1 Look at the table in your worksheet. When the load is 50kg, the 
length of the spring is given as 2.06 metres. 

2 Move the mouse pointer to the last data point for Type A. The 
pointer message should be 

Series “Type A” Point “50” (50,2.06) 

Be sure to point to the data point, not the trendline. 

3 With that message showing, click the mouse (to select all data 
points in that series). 

4 Keep pointing at that point and click again (to select just that point). 

5 Drag the data marker up the chart until the pointer message shows 
2.40 as the length of the spring. 

6 Release the mouse button. 

7 Confirm that this new value (load 50, length 2.40) has replaced the 
old value in the table on your worksheet. 

8 Note how the equation of the straight line has changed to deal with 
the new data. 

9 Click away from the chart to de-select it. 

Now you know how to “adjust” experimental results! 
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8 Chart data 
As time goes by, charts often need to be changed. For example, new data 
has to be added and old data removed. 

In this section, a column chart will be created and then altered in various 
ways as its data is changed. 

8.1 Creating the initial chart 
The data for this chart can be found on a separate worksheet. 

1 Click on the ChangeData worksheet tab. 

Here you will see the data to be charted. 

When creating a line chart in section 5, you just clicked in the table of data 
and the correct values were plotted. If you were to do the same here, the 
numbers 1996 and 1997 would be included in the chart as data points 
rather than as headings. So, this time it is better to select the data to be 
used in the chart. 

2 Select cells B7:D10  — the data points to be plotted plus the text for 
the categories on the X axis. 

3 Click on the Chart Wizard button. 

4 In the Chart Wizard - Step 1 of 4 – Chart Type window, select a 
Column chart with the first sub-type offered. 

5 Click on Next>. 

6 In the Chart Wizard - Step 2 of 4 - Chart Source Data window, 
click on the Data Range tab. 

7 Check that the Data range: is set to =ChangeData!$B$7:$D$10 
and that Series in: is set to Columns. 

8 Click on the Series tab. 

9 Check that the Category (X) axis labels: are set to 
=ChangeData!$B$7:$B$10. 

10 In the Series box, Series1 is highlighted and in the Values: box this 
can be seen to refer to C7:C10 (values for 1996). So, the name 
Series1 should be changed to a more meaningful text. 

11 Click in the Name: box and then click on cell C6 
(=ChangeData!$C$6 appears). 

12 Select Series2 in the Series box. 

13 Click in the Name: box and then click in D6 (for 1997 text). 

14 Click Next>. 

Note how the new text has appeared in the legend of the preview. 
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15 In the Chart Wizard - Step 3 of 4 – Chart Options window, click on 
the Titles tab. 

16 In the Chart title: box, type 

Funded proposals 

17 Leave the Category (X) axis: box empty since the subjects 
(Mathematics and so on) are self-explanatory. 

18 In the Value (Y) axis: box type 

Percentage by value 

19 The preview should now look fine so click on Next>. 

20 In the Chart Wizard - Step 4 of 4 – Chart Location window, leave 
the settings so that you Place chart: As object in: ChangeData. 

21 Click Finish. 

Now, if you adjust the size of the chart, set the font size to 8pt, and make 
the title bold 12pt, you should have a chart similar to the following one. 

Funded proposals

0

10

20

30

40

50

60

Chemistry All
Engineering

IT and
Computer
Science

Mathematics

P
er

ce
nt

ag
e 

by
 v

al
ue

1996
1997

 

8.2 Adding data 
Having seen how that chart was created, it is easy to understand how extra 
data can be added to it. Different techniques can be used and these are 
explained in sections 8.2.1 and 8.2.2. 

8.2.1 Dragging the fill handle 
First move your chart so that its top left-hand corner is in the region of B15. 
This will ensure that you have room for extra data in your table. 

1 In cell B11 type 

Physics 
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2 In C11 type 

54 

3 In D11 type 

49 

This is the new data that is to be added to your chart. 

4 Click on your chart so that handles appear round it and note how 
Excel has drawn three rectangles around the data used in that chart 
(probably green around 1996 and 1997; purple around the subjects 
and blue around the numbers in C7:D10). 

5 Add your new data to the chart by dragging the fill handle in the 
lower right-hand corner of D10 down to D11. 

6 The rectangle should now include Physics and its associated 
values. 

7 Look at the new chart — it should include Physics. 

8.2.2 Using drag and drop copying 
In cells G5:I5 there is more data that is to be added to the chart. 

1 Select those three cells. 

2 Point to the edge of the selection so that the mouse pointer changes 
to an arrow. 

3 Drag the selection to the chart and drop it there (let go of the 
mouse). 

 

At the moment you have two series in your chart (1996 and 1997). You do 
not want to add another series, you want to add new points: 

4 In the Paste Special dialog box, change the Add cells as setting to 
New point(s). The Values (Y) in Columns setting is correct. 

5 Click on OK. 
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6 Check that Materials and its associated values have been added to 
the chart. 

Note: Another method is to click on the chart and select Add Data from the 
Chart menu. 

8.3 Removing data 
Having created a chart and perhaps added extra data to it, it is quite likely 
that you may decide that you want to remove some of the data. 

You may wish to remove a whole series (like 1996) or a particular category 
(like Mathematics). 

8.3.1 Removing a series 
To remove the 1996 data: 

1 Make sure that the chart is selected (has handles). 

2 Click in any one of the 1996 regions — all of them will be selected 
automatically. 

3 Press the Delete key on the keyboard. 

4 Check that only 1997 data is now displayed and then immediately 
press the Undo button to restore 1996 values — they will be needed 
later in this tutorial. 

When removing a series, do not 
• clear the data from the worksheet — a blank series will be shown in 

the chart 
• delete the range (remove the cells) containing the 1996 values from 

the worksheet — you will get an error message. 

8.3.2 Removing data points 
There are three ways of removing data points. 

Method 1 

As an example, remove Chemistry from the chart: 

1 Make sure your chart is selected. 

2 From the Chart menu, select Source Data. 

3 Click on the Data Range tab. 

Usually you will be able to change the setting in the Data range: box (either 
by typing or by selecting a range on the worksheet) to achieve the desired 
effect. However, this particular chart is more complicated than the average 
one — the quite separate Materials data was added at a later stage. So for 
this chart, 

4 In this Source Data dialog box, click on the Series tab. 
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5 In the Series box, select 1996. 

6 In the Values: box, change $C$7 to $C$8 (so that Chemistry is 
excluded). 

7 In the Series box, select 1997. 

8 In the Values: box, change $D$7 to $D$8 (to exclude Chemistry for 
that year also). 

9 In the Category (X) axis labels: box, change $B$7 to $B$8 (to 
exclude the Chemistry label). 

10 Click on OK. 

11 Check that Chemistry has gone from the chart but that the other 
subjects are still there. 

That Series tab gives you complete control over your chart since you can 
change not only the data values but also the names of the series (that 
appear in the legend) and the labels to be used for the Category (X) axis. 

Note:  You will have seen that in the Source Data dialog box with the 
Series tab selected, you are given the opportunity to select a series and 
click on a Remove button. This is another way of removing a series from a 
chart. 

Method 2 

In some circumstances, you can remove data from a chart simply by hiding, 
on your worksheet, those values that are to be excluded from the chart. 
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Try excluding Mathematics from the chart as follows: 

1 Right-click on the row number 10 and select Hide. 

2 Check that Mathematics has gone from the chart. 

Method 3 

You can use this method if Excel draws coloured lines around the chart’s 
data when you select your chart. If the lines are not there (perhaps 
because, as in this case, the chart was built from disjoint data), you will 
have to use Method 1 or Method 2. 

Make sure your chart is selected, then get hold of the fill handle in the 
bottom right-hand corner of the rectangle surrounding the data and drag it 
up one or more rows so that the data you wish to remove from the chart is 
no longer inside the rectangle. Always check that the excluded data is no 
longer displayed in the chart. 

Clearly this method can only be used to remove data from the end of the 
list. So, if you want to remove data from the middle using this method, you 
will have to rearrange your list so that the data to be removed occurs at the 
end. This is somewhat fiddly so you may in such circumstances prefer to 
use another method. 

8.4 Changing the plot order 
Sometimes a chart looks better if the order in which the series are plotted is 
changed. Although it makes more sense in this chart to have 1996 before 
1997, try changing the order as follows: 

1 Make sure that your chart is selected. 

2 Select the 1996 (or the 1997) series by clicking on it. 

3 From the Format menu, choose Selected Data Series. 

4 Click on the Series Order tab. 

5 In the Series order: box, select 1997 and click on the Move Up 
button. 

6 Click on OK. 

7 Look at the effect in your chart (1997 before 1996). 

9 More about charts 

9.1 Combination charts 
Two or more chart types can be used in the same chart. Some 
combinations, such as line-over-column charts, are included in the 
Custom Types on offer in the Chart Wizard – Step 1 of 4 – Chart Types 
dialog box. If you cannot find the particular combination you want, design 
your own. 
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As an example, the chart shown below can be created from the data on the 
worksheet IceCream. 
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1 Click on the IceCream worksheet tab. 

2 Select the cells B4:I6 (take care to omit the heading Sales of ice 
cream cones). 

3 As a first step, create a column chart with chart title Ice cream 
sales. 
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4 Having done that, format the Y axis so that 500 is the maximum 
number rather than 450. 

The temperatures are to be displayed using markers, so 

1 Click on one of the Temperature columns (all will be selected). 

2 From the Chart menu, select Chart Type. 

3 Choose a Line plot. For Sub type select the first one on the second 
row (Line with markers displayed at each data value). 

4 Click OK. 

It does not make sense to measure both the temperature and the cones on 
the same scale. A second scale can be introduced as follows: 
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1 Click on one of the Temperature data points (all will be selected). 

2 From the Format menu, select Selected Data Series. 

3 Click on the Axis tab. 

4 In the Plot series on box, select Secondary axis. 

5 Click on OK. 

A new axis will appear on the right-hand side of the chart. The tick marks 
on this axis will probably be at every 5 degrees and so will not lie neatly on 
the horizontal grid lines. It would be better to put the tick marks at every 7 
degrees. 

1 Right-click on the right-hand temperature axis. 

2 Select Format Axis. 

3 Click on the Scale tab. 

4 Change the Major unit setting to 7. 

5 Click OK. 
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All that now remains to be done is to add titles to the axes. 

1 Right-click on the Chart Area and select Chart Options from the 
sub menu. 

2 Click on the Titles tab. 

3 For the Value (Y) axis: enter the title 

Number of cones sold 

4 For the Second value (Y) axis: enter the title 

Temperature in degrees C 

5 Click OK. 

6 Click away from the chart to de-select it. 
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9.2 Adding your own design to the custom types 
If you design a complicated chart and know that you will need to produce 
other charts like it in the future, you should consider adding your design to 
those custom types already offered. 

1 Prepare your chart (the ice cream one could be used as an 
example). 

2 Select the chart. 

3 From the Chart menu, select Chart Type. 

4 Click on the Custom Types tab. 

5 In the Select from group, click the User-defined button. 

6 Click on Add. 

7 In the Add Custom Chart Type dialog box, enter a suitably 
descriptive name for your chart (and a few words describing it if you 
wish). 

8 Click OK. 

9 In the Chart Type dialog box, click OK. 

Custom chart types are stored in workbooks. The built-in custom chart 
types are in Xl8galry.xls; your own custom chart types are in Xlusrgal.xls. 

9.3 Picture charts 
Excel can create picture charts where the values are represented by 
graphic images rather than ordinary columns or lines.  
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For example, to create the chart shown above, you would have to: 

1 Create a column chart in the usual way — you could use the chart 
created in section 9.1 if you wish. 

2 Right-click on one of the columns (all are selected). 

3 From the shortcut menu, select Format Data Series. 

Guide 34: Creating charts in Microsoft Excel 2003 38



4 With the Patterns tab selected, click on the Fill Effects button. 

5 In the Fill Effects dialog box, click on the Picture tab. 

6 Click the Select Picture button. 

7 Navigate to the picture you want. The picture used for the cones in 
the chart above is in T:\its\Excel\cone.bmp 

8 Click on Insert. 

9 In the Fill Effects dialog box, set the Stack and scale to: button in 
the Format box to 50 Units/Picture. 

10 Click OK. 

11 In the Format Data Series dialog box, click OK. 

9.4 Logarithmic scales 
When plotting some data, you may find that a log scale is more appropriate 
than a linear one. Experiment on a different worksheet as described below: 

1 Click on the LogScales tab to move to a worksheet containing the 
following data: 

1.1 10
2.2 200
3.1 3000
6.2 40000
7.1 500000
8.2 6000000

2 Create a scatter plot in the usual way. 
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3 Point to the Y axis (pointer message Value (Y) axis) and right-click. 

4 Select Format Axis from the shortcut menu. 

5 Click on the Scale tab. 

6 Click in the Logarithmic scale box. 

7 Click OK. 

You may like to display the Y axis minor gridlines as well as the major ones 
(see section 7.3) and delete the legend. 
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9.5 Display units 
When the values on your chart are large numbers, the text on the axis can 
be made shorter, and more readable, by changing the display unit of the 
axis. Experiment on a different worksheet as described below: 

1 Click on the DisplayUnits tab to move to a worksheet containing the 
following data 

12 1,000,000
23 5,200,000
34 15,000,000
45 22,000,000
56 33,444,000
67 44,555,000

2 Create a scatter plot in the usual way. 

0

10,000,000

20,000,000

30,000,000

40,000,000

50,000,000

0 20 40 60 80

Series1

 

3 Point to the Y axis (pointer message Value (Y) axis) and right-click. 

4 Select Format Axis from the shortcut menu. 

5 Click on the Scale tab. 

6 Click on the 6 in the Display units: box and select Millions. 

7 Click OK. 
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Numbers up to 50 are now displayed on the chart with a Millions label to 
indicate that the units express millions. 

9.6 Smoothing lines 
If, having created a Line or XY (Scatter) chart, you decide that you would 
like to smooth one of the lines: 

1 Select the series to be smoothed. 

2 Select Format | Selected Data Series. 

3 In the Format Data Series dialog box, click on the Patterns tab. 

4 Tick the Smoothed Line box. 

5 Click OK. 

Note: This is not the same as the exponential smoothing available in the 
Analysis Toolpak. 

9.7 Missing values 
Excel usually ignores blank cells. If you want to change the way in which 
missing data values are being treated: 

1 Select the chart. 

2 Select Options from the Tools menu. 

3 Click the Chart tab. 

4 Choose one of the settings for Plot empty cells as: 

Not plotted (leave gaps) 
Zero 
Interpolated 

5 Click OK. 

If you interpolate, Excel will just use a straight line to bridge the missing 
value gap. 

Note that in this dialog box you can also arrange to plot hidden cells (clear 
the Plot visible cells only checkbox). 
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10 PivotChart reports 
A PivotChart report combines the summary of data in a PivotTable report 
with the benefits of a chart. You should consider using one when you want 
to be able to quickly change between different ways of viewing the same 
data.  

When you design a PivotChart report, Excel automatically creates an 
associated PivotTable report. Indeed, if you already have a PivotTable 
report, it can be used to create the PivotChart report. There is information 
about PivotTables in Guide 36: Lists and data management in Microsoft 
Excel 2003. 

Any chart type except for xy (scatter), bubble or stock, can be used for a 
PivotChart report. 

Some suitable data with which to experiment can be found on the 
worksheet called Stationery. 

1 Click on the Stationery worksheet tab. 

2 To base the report on this data, click anywhere within the list. 

3 From the Data menu, select PivotTable and PivotChart Report. 

4 In the PivotTable and PivotChart Wizard – Step 1 of 3 window, 
make sure that the Microsoft Excel list or database option is 
selected and under What kind of report do you want to create? 
select PivotChart report (with PivotTable report). 

 

5 Click Next >. 

6 At Step 2, check that the data range is set to $A$1:$E$75 and click 
Next >. 

7 At Step 3, select New worksheet as the place to put the PivotTable 
report and click Finish. 
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Drag items from the PivotTable Field List window to the chart region: 

1 Drag Item to the Drop Category Fields Here region. 

2 Drag Item to the Drop Data Items Here region. 

3 Drag Name to the Drop Series Fields Here region. 

4 Drag Unit Cost to the Drop Page Fields Here region. 
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5 Click on the worksheet between this Chart sheet and the Stationery 
sheet; that is where the PivotTable report has been placed. 

 

Now experiment with some different settings: 

1 On that sheet, in cell B3, click on the 6 beside Name, remove the 
ticks from beside John, Linda, Mary and Melissa but leave the tick 
beside Paul. 

2 Click OK and note how the display has changed (only Paul’s data is 
visible). 

3 Move to the chart sheet and see how only Paul’s purchases are now 
displayed. 

4 On the chart, change the Name settings (perhaps to show Paul and 
Melissa). 

5 Look at the worksheet PivotTable report and note how that again 
reflects what is shown on the chart. 

The PivotChart report and the PivotTable report stay in step. 

Once you are satisfied with a particular layout, formatting can be applied to 
the chart in the usual way and the chart type can be changed. Formatting is 
not retained if you later change the layout. 
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11 Miscellaneous 

11.1 Graphics 
Graphics can easily be added to charts and are a useful way to draw 
attention to a particular feature or to provide an explanation. You may 
decide that you would like to add an arrow and some text to your chart.  

Experiment using a chart you created earlier, perhaps one on the Springs 
worksheet. 

Whatever you are doing, you should first make sure that the Drawing 
toolbar is visible: 

1 Select View | Toolbars | Drawing. 

There are two possible scenarios: 

• the graphics are confined to the area of the chart 
• the graphics are partly/completely outside the chart area 

Add your graphics: 

2 Click on the chart to select it. 

3 Click on the Arrow button on the Drawing toolbar. 

4 Draw an arrow on your chart. 

5 Click on the Text Box button on the Drawing toolbar. 

6 Draw a box and type a message in it. 

7 Click away from the text box. 

If your graphics are confined to the area of the chart, you can move the 
chart and the arrow and text will move with it. 

If your graphics are partly outside the chart area, the arrow and text will not 
move with the chart unless you also: 

1 Select the chart, arrow and text box (using Shift+click). 

2 Right-click on this selection. 

3 Select Grouping | Group. 

4 Click away from the selection. 

Note: A quick way of adding text to a chart is to select the chart, type your 
text (it appears on the formula bar), press Enter, and drag your text (which 
will be in a text box somewhere on the chart) to the right place. 

11.2 Printing a chart 
To print a chart that is on a separate chart sheet: 

1 Activate the chart sheet and print as usual. 

To print a chart that is an object on a worksheet: 
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1 Select the chart and choose File | Print — the chart will be printed 
on its own. 

or 

Select an area of the worksheet containing the chart; choose File | 
Print and change the Print what setting to Selection — the chart 
will be printed together with the worksheet cells that were selected. 

11.3 Taking a picture of part of your worksheet 
Excel offers two quite different ways of taking a picture of part of your 
worksheet: 

• using the Camera button 
• using the Copy Picture command 

11.3.1 Camera button 
Using this technique, a picture of a range of cells can be taken and then 
pasted in any worksheet. Since the copy is a linked image, when the values 
in the original cells change, so do the values in the image cells. 

To display the Camera button, 

1 From the View menu, select Toolbars. 

2 Select Customize. 

3 In the Customize dialog box, click on the Commands tab. 

4 Select the Tools category and scroll until you can drag the Camera 
button on to any existing toolbar. 

5 Click on the Close button in the Customize dialog box. 

To take the picture: 

1 Select the range of cells. 

2 Click the Camera button (the pointer changes to a cross hair). 

3 Move to the destination worksheet. 

4 Click the cross-hair pointer where the top left-hand corner of the 
picture is to be. 

11.3.2 Copy Picture command 
The Copy Picture command creates an image that will not change; this 
image is not linked. Pictures created in this way can be added to Excel 
worksheets or to documents created in any application that supports the 
use of the Clipboard. 

1 Select the range of cells, object or chart that is to be copied. 

2 Hold down the Shift key and from the Edit menu select Copy 
Picture. 
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3 In the Copy Picture dialog box, make sure that As shown on 
screen is selected in the Appearance box. 

4 In the Format box, click on Picture. 

5 Click OK. 

6 Activate your Word document (or wherever the picture is to go). 

7 Select either Edit | Paste or Edit | Paste Special (depending on the 
control you want). 

12 Finally 
If you wish to keep the changes you have made to the workbook, save it 
now. 

1 From the File menu, select Save As. 

2 Make sure the choices of drive and folder are suitable. 

3 Click on Save. 

Then close any open workbooks and quit Excel. 

If you are using the Networked PC service, don’t forget to logout. 

13 Other Excel documentation 
Other ITS documentation about Excel includes: 

Guide 33: An introduction to Microsoft Excel 2003 

Guide 35: Using formulae and functions in Microsoft Excel 2003 

Guide 36: Lists and data management in Microsoft Excel 2003 

Guide 39: Introduction to using macros in Microsoft Excel 2003 
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